Challenge #1 Grid: SOLVED


#23

some one here on this thread has given the answer away… look carefully and change a few code on it. You should have it!


#24

do you think its probably because of typo - “length”?

it is capital letters but may be missing a colon like such —
= GRID.length;

you also need to “return an array”


#25

I tried with and without capitals letters and it didn’t work


#26

Cannot figure this out. I’ve gone through all the relevant pages on the WS3 site and tried the verbatim solution given in this thread, plus modifications to it, but I’m stumped. Has anyone found any other helpful websites for learning how to do this?

I’m assuming that it’s something with GRID.length, but nothing is working for me.

As an aside, is there any feedback when you hit “Solve” if you’re wrong, or only once it’s correct? I’m asking because nothing happens when I hit “Solve” and I don’t know if the page is just being buggy for me.

Thanks!


#27

try this

countRows = ()=> {

return GRID.length;
};


#29

Thanks for the assistance. I really appreciate that you took the time!

I tried that and it didn’t quite work, but for the first time since the Challenge started, I finally got feedback on my code when I hit “Solve” (i.e. it said it ran, but wrong result, or it didn’t run, etc.). Previously I had no feedback at all when hitting “Solve”. I used the same code I’d tried on the first day today, and this time it was successful, so I think that it was a system error and that nothing was being recognized, regardless of correct/incorrect.


#30

Hey!

Here are some useful links with information specifically about the first challenge:

https://www.welookups.com/js/js_functions.html